Back to overview
Downtime
Complete downtime
Mar 11 at 04:21pm CET
Affected services
Flows application
Backend
Website
Resolved
Mar 11 at 04:36pm CET
We are back! All our services should be up and running. Thanks for bearing with us.
Affected services
Website
Backend
Flows application
Created
Mar 11 at 04:21pm CET
High spike in traffic to our services overloaded our infrastructure. We are working to fix the problem as quickly as we can.
Affected services
Website
Backend
Flows application